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Scott Studios and WideOrbit settings for DEVA
RDS/RBDS Encoders

Scott Studios SS32 automation software along with their DSM32 communication module is
fully compatible with several devices from DEVA wide range RDS/RBDS product line:

*  SmartGen Mini - UECP Compatible, Compact RDS/RBDS Encoder with LAN & USB
Connectivity;

* SmartGen 4.1 - UECP Compatible RDS/RBDS Encoder with LAN & USB Connectivity;

*  SmartGen 5.0 - Professional Dynamic RDS/RBDS Encoder, RS- 232, USB & TCP-IP Ports,
UECP Compatible;

*  SmartGen 6.0 - Professional Dynamic RDS/RBDS Encoder, RS- 232, USB & TCP-IP Ports,
UECP Compatible.

The following instructions are applicable for IP and SmartGen over a network and are similar
for serial data.

Prior the configuring procedure, check SmartGen’s current version of the firmware. If the
utilized version is older than 2.7, an update is required. The latest version can be found on www.
devabroadcast.com/downloads

In order for the Scott Studios and WideOrbit software to communicate with SmartGen over a
network, the following settings should be applied:
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SMARTGEN ENCODER

In order for the following settings to be correctly applied,

the latest version of DEVA’s SmartGen

RDS/RBDS Encoders Manager need to be used. The most recent version can be found on www.

devabroadcast.com/downloads

1. Allow the usage of dynamic PS using SmartGen Encoders Manager (as depicted in the
screenshot), WEB Interface or the ASCII command DPSON=1,;

E SmartGen 6.0\06E70010 =NACN X
Hardware | BasicRDS |Advanced RDS | Data Sets | ODA I Consolel

PI @ PTY @ Ms & TA @ TP @

Pl FFEF CALL ———  RDS [1L-RockMusic ~| REDS [11-Oldies v [wusic ~] [ oFF| Tmeout | 1} min,

PS @ DefaultPs PTYM @ [OI

SMARTGEN SMARTGEN  Timeout 02| min. SMARTGEEN [Shereo v] [No Artificial Head Y] [Not Compressed v] [DyﬂamicPTY Y]

RT &  AF List @

....... L e L e . R
Remaove trailing Method 87.6

SmartGen €.0 - Dynamic RDS/REDS Encoder — WWW.DEVABROADCAST.COM [T [¥]spaces before -
transmitting Mo AF

Dynamic PS @

....... L e |
Text SmartGen €.0 - Dynamic RDS/RBDS Encoder — WWW.DEVABROADCAST .COM
A —
sEAC \ e
a 2
W % B
nann :
Default Dynamic PS == Add AF m
------- e e s e e [

Text Smartfen €.0 - Dynamic RDS/REDS Encoder — WWW.DEVABRORDCAST COM  Timeout 15 min. ’H Save Changes ] [@ Revert Changes ]
H Backup Encoder E D EVAQ [SmartGen 6.0 - [TCF] demo.devabroadcast.com: 5160 v] ’@ Disconnect]
& Restore Encoder BROADCAST

06E7001D  FW:D2.11 [eLTNYadh]

2. Determine the appropriate mode of displaying of the dynamic PS text using SmartGen
Encoders Manager, WEB interface or the ASCII command PARSE.

When PARSE is set to 0 (words centered) or 9 (words justified to the left), parsing will send
the short words together. Long words (up to and including 8 characters) are sent individually/
separately. Words exceeding 8 characters are “sidestepped” through two or more consecutive
displays. When PARSE is set between 1 and 8, the message is scrolled from 1 to 8 characters at a

time without dividing into word groups.

Example:
PARSE=0
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3. Set the speed with which the dynamic PS will be translated (scrolled). The speed depends
on the ratio between the transmitted RDS 0A groups and other groups. For firmware version 2.7
and higher and software version 0.1.2.94 and higher, “Dynamic PS Speed” (DPSS) could be set.
This function is accessible via SmartGen Encoders Manager (as depicted in the screen shot), WEB
Interface or the ASCII command DPSS.

Example:
DPSS=5
B SmartGen 6.0\06E7001D SRICE X
Hardware | Basic RDS | Advanced RDS | Data Sets | ODA I Consolel

PI @ PTY @ Ms 8 TA a TP ]
Pl FFEF  CALL ——— RDS [ 11-Rock Music ~| REDS [11-Oldies ~| [musc - [ ] OFF] Timeout | 12| min.
PS @ DefaultPs FTYN @ [OI
SMARTGEN SMARTCEEN  Timeout 02| min, SMARTGEN [Shereo v] [No Artificial Head V] [th Compressed V] [Dy‘namicPTY V]
RT & AF List a

....... e L P T
Smartfen €.0 — Dynamic RDS/RBDS Encoder — WWW.DEVABROADCRST . COM

Remove trailing

Method 87.6 =
[CJa® [¥]spaces before :

transmitting No AF

Dynamic PS5 @

| - -

_______ L
Text SmartGen €.0 - Dynamic RDS/RBDS Encm;

3
4
[

GeAC

Q
= %

Default Dynamic PS5
_______ L e |

Text SmartFen &.0 - Dynamic RDS/RBDS Encoder — WWW.DEVABROADCAST . COM

[ Backup Encoder E D E v A@
& Restore Encoder BROADCAST

Timeout 1= min.

= Save Changes Revert Changes

[SmartGen 6.0 - [TCP] demo.devabroadcast.com: 5160

V] ’@ Dismnnect]

06E7001D  FW:02.11 [&TiTiTTav]

WARNING: The current Group Sequence will be obliterated (lost) and replaced with a new
one, containing 0A and 2A groups only.
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SCOTT STUDIOS SS32 SOFTWARE CONFIGURATION

Prior the configuring procedure, make sure that all necessary preliminary adjustments to DSM32
and SS32, relating to the communication and export of data between the two modules have been
applied. If not and for further information, please refer to Scott Studios SS32 User Guide (page 6)
and Data Service Module: DSM32 (page 37).

In order for the DSM32 (DATA SERVICES MODULE) to start exporting Now Playing data to
SmartGen, click on the RDS/RBDS Campaign button, placed the main screen.

RDS/RBDS Campaigns

The Campaign configuration screen allows you to define the RDS/RBDS encoder output
settings, and also to set specific rules for text export. For example, you could set a campaign to
display the station slogan or advertiser sponsored text during commercials, or to display upcoming
concert information for a specific artist when their newest song is on air.

As depicted on the screenshot below, the following settings should be applied:

DSM32

Configure Campaigns
RDS Encoder

Type [Inovonics 713 ~| IPAddress [123.456.789.322 Port |5007

Protocol ‘UDP j PS IStﬂtic LI Default PS Msg |Rock 104
Refresh Rate (secs) |1.8 :" [~ RadioText (64) Radio Freq |104.1

Slogan [104.1 FM Your Home For Rock

Slogan 7.2 secs

Options - 5
[ Ignore '"NONT' Type |[¥ Publish Spot Titles

Campaigns (Highlight Then Use Button [DoubleClick = Edit] )
Default Campaians

<create new> Edit |

1. Type — Select the encoder type from the drop-down menu. There are two available options:
- The first is to choose Inovonics, as SmartGen encoder covers the same set of commands
relevant to Specifying PS, Dynamic PS (DPS) and RadioText.
- The second option is to choose “User Defined”.

2. IP Address and Port — Specify the destination IP address and Port Number for the RDS/
RBDS encoder.
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3. Protocol — Select the protocol to be used from the drop-down list. Please refer to SmartGen’s
complete User Manual for further information on which Protocol should be used. The following
options are available:

- Selections for TCP (Transmission Control Protocol) and UDP (Universal Datagram Protocol)
will send ASCII formatting. If you have chosen Inovonics as an encoder type, you will be limited
to TCP output only;

- The UECP (Universal Encoder Communication Protocol) selection will send modified UECP
encoding over UDP. This protocol type is not recommended;

- UECP2 will send standard UECP encoding over UDP. DEVA’s SmartGen encoders are fully
compatible with UECP EBU SPB490 Version 7.05. Thus, we recommend the usage of this protocol

type.

4. PS — The PS setting defaults to Static mode. Use the drop-down menu to access the advanced
option that will allow sending Dynamic PS instead of Static.

- The default Static mode indicates that text events will be sent to the RDS/RBDS encoder in
8-character (PS=segments), in Block mode;

- When Dynamic PS instead of static (prefixed as DPS=) is sent to SmartGen, the RDS/RBDS
encoder will parse the output text internally and additional parameters should be configured on the
encoder.

NOTE: The Dynamic PS output is limited to 64 characters at a time. Campaigns outnumbering
the character limit will be truncated.

5. Default PS Msg — Enter a default PS message (up to 8 characters long);
6. Refresh Rate — Select the default refresh rate (in seconds) from the drop down menu;
7. Radio Text (64) — In order to send the identical campaigns as radiotext (i.e. TEXT=) to the
RDS/RBDS encoder, the Radio Text (64) should be selected;
- Radio Text (64) will send the identical campaigns as radiotext (i.e. TEXT=) to the RDS/
RBDS encoder. Radiotext, as the Dynamic PS also has 64-character limit and campaigns over this
character limit will be truncated. It may be sent concurrently with either Static OR Dynamic PS.

8. Radio Freq — Specify the radio frequency of the station being configured;

9. Slogan — Enter the station slogan. The field next to the slogan displays the total time needed
for displaying of the slogan, depending on the Refresh Rate previously selected.

Options

Ignore ‘NONT’ Type: Selecting this option will prevent NONT (Do Not Play on Internet)
events from being encoded over SmartGen.
Publish Spot Titles: Selecting this option will allow spot titles to be encoded from SmartGen.
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Set up the Default Campaign

Double-click the “Default Campaigns” line in the Campaigns screen. Replace the “No Value”
text with your custom text fields along with Title and Artist wildcards (in the drop down menus).
This information will be sent (from top to bottom) to the RDS/RBDS encoder while defining
music cuts are playing.

Leaving the ‘NoValue’ text in a field will omit that field from being sent to the RDS/RBDS
encoder. Once you have specified your Default Campaign settings, click “Save” to return to the
Campaign configuration.

DSM32
Edit Default Campaigns
Music Campaign
Text Part #1 |Now Playing

Title or Artis|Title -

Text Part #2|hy

Title or Artis|Arlist =

Texi Part #3|on Rock 104

Spot Campaign
Text Part #1|Tell

Spot Name Appears Here

Text Part #2 ‘Ruck 104 sent you...

Moter Use Special Text "Novalue" to skip owver any field. Cancel| [[Save?
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Software License Agreement

NOTE: THE ENCLOSED SOFTWARE IS SOLD ON THE CONDITION THAT THE PURCHASER
AGREES TO THIS SOFTWARE LICENSE. PLEASE READ THE FOLLOWING TERMS AND
CONDITIONS CAREFULLY. BY INSTALLING, COPYING, OR OTHERWISE USING THE
SOFTWARE, YOU AGREE TO BE BOUND BY THE TERMS OF THIS SOFTWARE LICENSE.
IF YOU DO NOT AGREE WITH THE TERMS AND CONDITIONS OF THIS SOFTWARE
LICENSE, YOU MAY NOT USE OR COPY THE SOFTWARE AND SHOULD PROMPTLY
CONTACT YOUR SALES REPRESENTATIVE FOR INSTRUCTIONS ON RETURN OF THE
SOFTWARE.

Scott Studios, LLC (“Scott Studios”), a wholly owned subsidiary of dMarc Broadcasting, Inc.
(“dMarc”) agrees to grant a nonexclusive license to the Customer to use the enclosed software
programs ("Licensed Programs") and documentation under the following terms and conditions

applicable to the license of program products.

1. LICENSE. Scott Studios shall grant and the Customer shall accept upon the terms and
conditions hereinafter set forth nontransferable and nonexclusive licenses to use the PROGRAM
PRODUCTS including basic material, hereinafter referred to as "Licensed Programs" and related
optional materials, hereinafter referred to as "optional materials”, listed on Schedule B attached
hereto and incorporated herein by reference and those which are ordered from time to time by the

Customer, subject to written confirmation by Scott Studios and added thereto.

The license hereinabove referred to in the preceding paragraph is effective from the date hereof
and shall remain in force until terminated by Scott Studios upon a breach by Customer of the
terms and provisions of this Agreement. The Customer shall, upon reasonable notice by Scott
Studios, be given the opportunity to cure such breach within a time to be determined by Scott

Studios acting reasonably.

2. USE OF PROGRAMS AND OPTIONAL MATERIAL. Each program license granted under
this Agreement authorizes the Customer to use the licensed program in machine readable form
on the machines and computer hardware which the Customer has purchased in accordance with
this Agreement. NO RIGHT TO PRINT OR COPY, IN WHOLE OR IN PART, THE LICENSED
PROGRAMS OR OPTIONAL MATERIALS IS GRANTED HEREBY EXCEPT AS HEREINAFTER
EXPRESSLY PROVIDED. Removal, emulation or reverse-engineering of all or any part of the
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Licensed Programs constitutes an unauthorized modification to the Licensed Programs and is

specifically prohibited.

3. PROGRAMMING SERVICES. Scott Studios shall use its best efforts to correct any errors
promptly, but shall not be liable for any incidental or consequential damages caused by said
errors. Scott Studios may, from time to time, revise or update the Licensed Programs and/or
optional materials, and in so doing, incur no obligation to furnish such revisions or updates to the

Customer.

4, PERMISSION TO COPY OR MODIFY LICENSED PROGRAMS. The Customer shall not
copy, in whole or in part, any Licensed Programs or optional materials which are provided by
Scott Studios in printed form under this Agreement. Any Licensed Programs or optional materials
which are provided by Scott Studios in machine readable form, may be copied in whole or in part,
in printed or machine readable form, for use by the Customer for archive or emergency restart
purposes provided, however, that no more than two copies will be in existence by any Customer
at any one time without prior written consent from Scott Studios. The original and any copies of
programs and/or optional materials in whole or in part which are made hereunder shall be the

property of Scott Studios.

5. PROTECTION AND SECURITY. The Customer agrees not to provide or otherwise make
available any program or optional material including but not limited to flow charts, logic diagrams
and source code, in any form to any other person without prior written consent from Scott
Studios.

6. RESPONSIBILITY OF CUSTOMER. The Customer shall be exclusively responsible for
the supervision, management, and control of its use of the Licensed Programs, and/or optional

materials, including but not limited to:

a. Assuring proper machine configuration, program installation, audit controls, and

operating methods;

b. Establishing adequate backup plans, based on alternate procedures, in the event

of a licensed program malfunction;

C. Implementing sufficient procedures and check points to satisfy its requirements
for security and accuracy of input and output as well as restart and recovery in the event

of a malfunction, and;
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d. Assuring that Customer has appropriate license and rights to all copyrighted
musical recordings pre-loaded as part of the Licensed Programs and/or optional
materials. The Customer agrees to indemnify, defend and hold harmless Scott Studios
and its affiliates to the fullest extent permitted by applicable law from and against any and
all loses, claims, damages, liabilities, settlement costs and expenses, including without
limitation, cost of preparation and reasonable attorneys fees, as a result of or arising from
any actions or proceedings by a third party in connection with the unauthorized
reproduction, adaptation, performance, display or distribution of such copyright protected
works.

The Customer agrees that it will take appropriate action with its employees, by agreement or
otherwise, to satisfy its obligations under this Agreement with respect to use, copying and

protection and security of Licensed Programs and optional materials.

7. RISK OF LOSS OF LICENSED PROGRAMS. If any licensed program or optional
material is lost or damaged during shipment, Scott Studios will replace the licensed program or
optional material and program storage media at no additional charge to the Customer. If any
licensed program or optional material is lost or damaged while in the possession of the Customer,
Scott Studios will replace the licensed program or optional material for a fee based on the then
current schedule of charges, but Scott Studios shall not be required to replace any storage media
damaged or lost while in the Customer's possession. Third party software products (software

products not licensed by Scott Studios) are not subject to the terms and conditions of Section 7.

8. LIMITED WARRANTY. Each licensed program and/or optional material will conform in
substantial accordance with the PROGRAM PRODUCT specifications published at the time of

manufacture for so long as a valid support agreement is in place.

THE FOREGOING WARRANTY IS IN LIEU OF ALL OTHER WARRANTIES, EXPRESS OR
IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE.

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT SHALL
SCOTT STUDIOS BE LIABLE FOR ANY DAMAGES WHATSOEVER (INCLUDING WITHOUT
LIMITATION, SPECIAL, INCIDENTAL, CONSEQUENTIAL, OR INDIRECT DAMAGES FOR
PERSONAL INJURY, LOSS OF REAL OR ANTICIPATED BUSINESS PROFITS, BUSINESS
INTERRUPTION, LOSS OF BUSINESS INFORMATION OR ANY OTHER PECUNIARY LOSS)
ARISING OUT OF THE USE OF OR INABILITY TO USE THE LICENSED PROGRAMS AND/OR
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OPTIONAL MATERIALS, EVEN IF SCOTT STUDIOS HAS BEEN ADVISED OF THE
POSSIBILITY OF SUCH DAMAGES. IF IN ANY CASE, SCOTT STUDIOS ENTIRE LIABILITY
UNDER ANY PROVISION OF THIS AGREEMENT SHALL BE LIMITED TO THE AMOUNT
ACTUALLY PAID FOR THE LICENSED PROGRAMS AND/OR OPTIONAL MATERIALS. Scott

Studios will not be liable for any claim or demand against the Customer by any other party.

This section shall be governed by the laws of the State of California. Some states do not allow
exclusion or limitation of incidental or consequential damages or the exclusion of implied
warranties, so the above limitation or exclusion may not apply to you. If the above limitations or

exclusions violate state or federal law, they shall be deemed null and void and unenforceable.

9. LIMITATION OF TIME FOR CLAIM. No action, regardless of form, arising out of any of
the transactions under this Agreement may be brought by either party more than one (1) year

after the cause of action has accrued, save and except for nonpayment of licensing charges.

10. GENERAL. This Agreement shall be governed by the laws of the State of California and
any controversy between the parties to this contract (Scott Studios and Customer) shall be placed
in the State of California and Customer agrees that venue and jurisdiction are properly placed
with the District Court of Orange County of the State of California. Should any of the provisions or
portions hereof be invalid under any applicable statute or rule of law, they are to the extent to be

deemed invalid, omitted.

11. REMEDIES. Scott Studios entire liability and the Customer’s exclusive remedy shall be at
Scott Studios option: (a) return of the price paid prorated for actual usage, or (b) upgrade of the
Licensed Programs and/or optional materials. THE CUSTOMER'S REMEDIES IN THIS
AGREEMENT ARE EXCLUSIVE.

12. VERIFICATION. THE CUSTOMER ACKNOWLEDGES THAT IT HAS READ THIS
AGREEMENT INCLUDING ALL PRINTED LANGUAGE, UNDERSTANDS IT, AND AGREES TO
BE BOUND BY ITS TERMS AND FURTHER AGREES THAT IT IS THE COMPLETE AND
EXCLUSIVE STATEMENT OF THE AGREEMENT BETWEEN THE PARTIES, WHICH
SUPERSEDES ALL PROPOSALS, ORAL OR WRITTEN, AND ALL OTHER
COMMUNICATIONS BETWEEN THE PARTIES RELATING TO THE SUBJECT MATTER OF
THIS AGREEMENT.
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Getting Started

On the left side of the main SS32 screen is the Event Log, or “Stack”. The top event is currently
on-air. The gray box to the left shows which device the audio is playing out of, and then counts

down the length of the event. If there is no event playing, it will display a Start button.

® STACK
|

4:24 (10:03 15 |

Don't mi

| Power Bar

COUNTDOWN

CLOCK AND

Directly below the on-air event are the next five events to air, each having a Start button next to it.
These events can also be started using the “F” keys on the keyboard. When started, the event

goes on the air and moves to the top event.
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Fade On-Air Audio

Clicking Start on an event in the stack while another event is on-air will start it immediately while

fading the on-air event.

The on-air event can be faded out completely by clicking the gray button next to the event. If
there is more than one item on the air, this button fades the most recently started event first. The

next event will not begin until the Start button is pressed.

Move Event

To move an event within the Stack, click the “label” area of the event to be moved. The event will
be highlighted with a dashed line around it. Click on the event in the position for the event to be

placed. The other events will be moved down.

Delete Event

To delete a single event, click on the “label” area of the event then click on the “Del” button just
below the Stack. Or, click the “Del” button before highlighting any events. A red circle with a red

slash will appear over the Start buttons. Simply click on the circle next to the event to be deleted.

Countdown Clock

The bottom center of the main screen displays the Countdown Clock. When an event starts, a
box will display a countdown for the Intro of the event. After the Intro countdown, a “pie” graphic
will display the remaining percentage until the end of the event. The “pie” will briefly display the
countdown time again at 60, 45, and 30-second intervals, and will count down from 15 seconds

until the end of the event.

Re-Cue

In addition to displaying remaining times, the Countdown Clock area also serves as a Re-Cue

button. Re-Cue is identified with a double blue circle beside events in the Stack.

Events that were not uploaded in time to cue up automatically, such as last minute news or
weather, will show a blank area where the Start button should be, and the event label will show

“File Not Found”. These events can be cued manually by clicking the Re-Cue (Countdown) area
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and then clicking the double-circle beside the event that has not cued. If the recording has

become available, the Start button will be displayed.

Events that are expired will also show a blank area where the Start button should be, and the

event label will show “End-Date Out of Range”.

The on-air event can be re-cued after a fade by clicking the Countdown Clock, then clicking the

double circle next to the top event. The event will start playing from the beginning.
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SS32 Main Screen

This section provides an overview of the main screen of the SS32 software. Note that some of
the buttons may be different depending on the configuration and additional options that were

purchased. The most common configuration and options will be addressed in this guide.

System Clock

The system clock is displayed in the upper left corner of the main screen. The clock will show an
orange color between 6 AM to 6 PM, and changes to a dark blue color during the evening and
overnight hours of 6 PM to 6 AM. The clock is set in HHMMSS format in Configuration -> Time

Functions.
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Back Timer

When SS32 is first started, the “time to launch” will display next to the system clock, which is set

in set in Configuration -> Misc-1 Settings.

This area also displays a Back Timer if set in Configuration -> Misc-1 Settings. The Back Timer
compares the time of each event added through to the next Target event, and the actual time until

the Target event is on-air. (Target events are set when the schedule is created).

If the total of event lengths up to the Target event is less than the actual time to the Target event,
the box will display the difference in Red. If the calculated event lengths are greater than the
actual time to the Target, the box will display the overage in Blue. The box will display “too far” if

there is no Target event found within the Search Depth set in the configuration.

Pre-Defined Liner Playback On/Off

Pre-defined (or “satellite”) liner playback is normally managed with commands in the schedule.
However, the SS32 system can be set to manually override any scheduled pre-defined liners
using the “Activate Manual Control via Hotkey & Auto/Man Button” in Configuration -> Satellite.

When this is set, a Green dot will appear just to the right of the Back Timer display, and the pre-
defined liners will play as scheduled. There are two ways to override playback of the pre-defined

liners:

e Click the Auto button to put the SS32 system into Manual mode. The dot will then turn

Red, indicating the pre-defined liners will not play when the closure is received.

e A Hot Button may be set as the disable button to keep the system in Auto mode. (Please
refer to the SS32 Configuration Guide, Satellite section, for setup). When this Disable

Button is clicked, the dot will turn Dark Red to indicate the pre-defined liners will not play.

Next Device Display

The Next Device bar, to the right of the Back Timer display, shows the next device the on-air
event and the next Hot Key will use. Devices are set in Configuration -> Playback Devices

according to the type of audio cards in the SS32.
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Message Bar

A message bar is located at the top right of the screen, just above the Hot Keys. Error messages
will be displayed in red in this area, as well as a progress bar when events are being uploaded to
the SS32 from other programs. This area will also display green informational messages if set in

Configuration -> System Settings.

Event Log [Stack]

The Event Log, also referred to as the “Stack”, is a column of six events that will air. To the right

of each Start button is the “label” area for each event. .
Linger

The first line contains the title of the event, and the Cran!)errles

~ T

artist or talent name is on the second line. Everybody Else Is Do g It...

The third line shows the following information: Intro/Event Length/Ending (usually F for fade or C
for Cold), then the category, event (cart) number with prefix, and time scheduled to air. The

fourth line will display comments or ‘trivia’ entered in the header.

Live Copy

Live Copy refers to live scripts that are scheduled in the log. When a Live Copy event is “played”,
it will display the text in a small box at the bottom of the Stack. Click in the window to close. Live

Copy will display on the second monitor in a dual-screen setup if set in Configuration -> Copy.
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Hot Buttons

Hot Buttons are displayed on the right side of the SS32 main screen. If there is a dual-monitor
setup, Hot Buttons can be opened on the second monitor. Simply click on the Hot Button to start

and end the event assigned to it.

Typically, Hot Buttons do not check events for
start/end dates or times, and will play regardless of
these restrictions.

If the “Liners+HotBtns Honor  Start+Stop
Date+Hour” setting is marked in the Configuration -
> Satellite page, Hot Buttons (and liners on satellite
closures) will observe the start/end date and time

restrictions.

Events can be added to the Hot Buttons using the Insert screen. (Insert screens are explained in
more detail below). Select the event in the Insert screen, and click the green Stack button. Exit

the Insert screen, and click the Hot Button to add the event.

Hot Buttons can also be programmed quickly by holding the ALT key on the keyboard while
clicking the Hot Button. Up to three lines of text can be entered to identify the Hot Button, and the
event category with the 4-digit event (cart) number is [T
entered for “Hot Key CatCode”. ok | cancel
HotKey Line#1  [Holiday
Hot Key Line #2 |uz—

Hot Key Last Line |1:08

Hot Key CatCode IBEDBBB?

When Dynamic Hot Buttons are in use, a selection of

button colors will be displayed at the bottom of the User

Input window.
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SS32 Additional Functions

The buttons along the bottom of the main screen provide more extensive functionality for the
SS32. The functions for the Green buttons (fourth and eighth from the left) are set in
Configuration -> Misc-2 Settings. The Left Green button can enable the following functions: Cart
Recorder, LazerBlade, VT (Record voice tracks), and Fade/No Fade. The Right Green button

can be configured with the same functions, along with Live Mode and Disabled.

Modes of Operation

Auto Mode

In Auto Mode, the SS32 system operates without user intervention based upon a schedule
compiled in the Merge32 program. Every event is started automatically by the End-of-Message
(EOM) signal placed when the event was recorded. When a new event is started by the EOM,

the previous event is automatically faded out.

CEE @ EENNE

Most events are scheduled in the log with a DA (for Digital Audio) designation in front of the 4-
digit event (cart) number. When SS32 is in Auto Mode, the on-air event will be faded out when
the next event starts. The speed of the fade is set in Configuration -> Playback -> Fade Speed
(tenths). Events that are scheduled in the log with a VO (for Voice Over) designation will not fade
out, but will play at full level until they end. Voice Tracks are designated as follows: JV = Generic
Voice Tracks; JU = Voice Track linked to previous event; JD = Voice Track linked to next event;

JB = Voice Track linked to both previous and next events; and JN = Voice Track not linked.
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Manual Mode

Clicking on the Auto button will immediately change the system to Manual Mode. Manual Mode

requires user input for every event in the schedule.

Each event must be started by the user, either from clicking the Start area, or through a remote
start button at the console. The console is used to fade out events — the console channel number
for each event is displayed in the Start area. SS32 can be configured in Misc-1 Settings to

display vertical bars in place of Start area in the Stack.

Most stations use a combination of Auto
and Manual operation. Usually the song
sweeps and stop sets run in Auto. Prior to
a live talk point, the user changes to
Manual, listens to the audio, and begins

talking based on the fade and the

Countdown Clock.

When finished, the next event is started

EEEEE
SoEEN YECEE

manually, and the user changes back to

Auto mode for the next sweep of music or

spots.

Live Mode

Live Mode is only available if set in

Configuration -> Misc-2 to appear on one

of the configurable green buttons. In this

mode, each on-air “deck” (next to play) is

assigned to a particular channel on your

console, with events loaded in “cart” spots

waiting to refill the deck.

e @
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Preview

Preview allows the user to hear the beginning and end of an event in the Stack. When Preview is
clicked, two circles appear in the label area for each event. Clicking the left circle will play the
event from the beginning, and the right circle will play the last 15 seconds (default). The end
length can be adjusted in Configuration -> Misc-1 Settings -> Preview/Pause. Click Preview

again to stop the playback and turn Preview off.

Hot Buttons will display double-circles (one inside the other) in Preview. Click the Hot Button to
preview the audio from the beginning, and click again to stop the preview. If it is a Rotator, the

next event on the Hot Button will be previewed without cycling the Rotator to the next event.

o

)

Preview Extended Preview

Extended Preview

If Extended Preview is enabled in Configuration -> Misc-1 Settings, clicking the Preview button
will display more extensive capabilities. The Preview button will enable six preview buttons on

the event label areas.

The right and left arrow buttons will move forward or back in the audio from the current location
the file according to the seconds displayed in the first circle. Click in the circle to change the
increments in seconds. The square button starts and stops playback. The second circle plays
the last 15 seconds of the event.

The rounded-corner button displays the audio length, and will change to the playback counter
during preview. This button also works as a “lock” to set the beginning of playback at the current
file position when it is pressed (a lock graphic will appear on the button). The lock cannot be set

unless the event is either currently being previewed, or has just been stopped.

The slider bar can be used to manually move the current playback position before previewing it.
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Log [More Events] Screen

The Log button opens the day’s log, starting at the present time, on the right side of the screen
over the Hot Buttons. If there is a dual-monitor setup, this screen can be opened on the second
monitor. The log will open with the current time/event at the top (shows upcoming events),
middle (shows both aired and upcoming events), or at the bottom (shows previously aired and on-
air event) according to the place set in Configuration -> Log Window. Previously aired events
will be in gray. Notice that the current event will show in gray with the time it started, and will

also show in its category color as the current item with the current time.

j | Cut  Clear Mkid  Del  Hooks Mulns
| i

£

76

>0El<< Ho More Words Berlin 346
>DEl<<= Tonightls The Hight Le Click 3:00
=0El<< If It Makes You Happy Grow, Sheryl an

10:33:00 Danger Zone Kenny Loggins 03:33

10:36:33 Don'tBe Stupid (YouKn Twain,Shania 3:32

10:40:06 I'm The Only One Etheridge, Melissa 4:00

10:34:06 One More Try TimmyT 3:25

1

10:49:35 One More Try TimmyT 3:29

>cpy<< Ho More Words Berlin 3:46
11:03:43 These Are Days 10,000 Manaics  3:31
1:07:14 I'mLike &Bird Furtado, Helly 3:93

To view ahead or behind in the schedule, use the scroll bar to the right, or the Up/Down buttons
just below the log. To get back to the current time/event, click the Now button to the left of the

Countdown Clock (“pie”).

The range of events that can be copied, moved, or deleted in the Log screen is set in
Configuration -> Log Window. To select events, click on the event, and then click on the Copy,
Cut, or Delete buttons at the top of the screen. Multiple events can be selected by holding down
the CTRL key while clicking on events. The Copy and Cut button graphics will change to
“Where?” when selected. The Clear button will clear out selections before the copy/move/delete
action is completed. Click on the position where the copied/moved event(s) are to be inserted.

All other events will be moved down.
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Copied events will show >cpy<< in the air time field in the current log as well as the event label in
the Stack. Cut events will display >mov<<. Deleted events will be removed immediately from
the current log and the Stack, but will show in the aired log with >DEL << in the air time field.

The MkGd [Make Good] button highlights the last event in the log that did not play. Continue to
click the MkGd button to review unaired events further back in the log. While searching, the
Mnins button becomes the MkDn [Make Good Down] button, allowing navigation of unaired
events in the opposite direction. The Cut button is not active while using the MkGd function.

Use the Copy function to put an unaired event back into the current log.

Hooks

The ability to set Hooks is an extra-cost item. Hooks must be set in the audio event in Cart

Recorder, and the event must exist in the current schedule before performing the following steps.

Cut Clear Make

Mk6d | Del

Gopy

mins = Click on the Hooks button at the top of the Log

« screen. The system will look ahead in the log
according to the range set in Configuration -> Log
Window -> Verifying Audio Files.

Events with Hooks set will show in the log with a

small purple tag to the right of the title.

Select the events for the Hook list, and click the
Make button at the top of the screen. (Clicking on a

selected event will de-select it).

The Hook List Editor screen displays a list of the events with the length of the hook. Additional
elements, such as beds, can be added to the Hook List using the Insert Elements buttons at the
top of the screen. To add an element to a button, go to the Insert screen and add an event to the
Stack button. Exit the Insert Screen, return to the Hook List Editor and click the Element button
to add the event. (Insert screens are explained in more detail below). The additional element will

be inserted above the currently selected hook.

Events and elements can be removed by selecting them in the list, then clicking the Remove
button at the bottom of the screen.
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When the Hook List is complete, click the Done button at the bottom of the screen. Blue Insert
arrows will appear in the Start area in the Stack. Click on the arrow in the position where the
Hook List is to be inserted.  The Hook List is initially inserted in the Stack as one expandable
(XP) event, with the Start area to the left being gray. The XP event will automatically expand four
seconds before it's on-air time, or the user can click in the Start area to ‘break out’ and view the
Hook List prior to that. The event labels will display the event name and artist, with the length of

the hook and a “DH" designation in front of the 4-digit event (cart) number.

Heook List Editor

—Insert Element:
AFTHYPE BE[ MATRIX BED | SCARY MUSIC [Empty] |

Emptl | [Empy] | Empt) | Empt) |

MATRIX BED /MATRIX BED BED 0038 01:23

Dig In /Kravitz, Lenny 301 4704 00:06

Look What You'/Jet 302 6874 00:04

Manual Insert

The Mnins button at the far right of the Log screen is used to manually insert events in the
current log. Enter the Prefix (audio type designation, usually “DA”"), Code (4-digit event/cart

number), and Category in the Input window.

The Label Text field is optional — the entry in this field displays in the current log screen as the
event title. Click OK, and click the blue Insert arrow where the event is to be inserted in the
Stack.

The event will display in the Log screen and Stack with >ins<< in the air time field. The title is
displayed in the Stack, but not the Log screen, unless it was entered in Label Text. The event

displays 0:00 for length in the Log screen until the event goes on air.

useroput
Prefix [pa
Code [s166
Category W
Label Text |
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Options

The Options button will open a menu with 14 selections. Click Cancel to return to the full main

screen with Hot Keys.

Load New Schedules

Every 20 minutes, the SS32 system will automatically compare the date/time stamp of all
currently loaded schedules with those in the schedule path (listed in Configuration -> Schedules),
and reload any that are different. If the current schedule has changed, it will ‘attach’ at the fourth
position in the Stack. The Load New Schedules button is used to force a reload of the current
day’s schedule. The button will change to Done when the reload is completed. If there are no
differences in schedules detected, the button will still change to Done, and a notation is made in
the AIR log.

Disable TouchScreen

The Disable TouchScreen button will temporarily disable the ‘touch’ functionality. The SS32
splash screen will appear, along with the instruction to press the ESC key to return to the main

screen with the touch functionality enabled again.

14 © 2006 Google, Inc.



Copy Today’s Air Log

Making a copy of the current Air Log creates a file for viewing, printing, or e-mailing the day’s
events up to the current time. The copied Air Log file is saved in the SS32\AXR folder with the
file name YYMMDD.AXR. This file can be viewed using Notepad. The SS32 will continue to
write events to the original Air Log in the SS32\AIR folder.

Named Schedules

Named schedules must be created in Merge32 and exist in the SS32\SKD folder with a 4-

character file name and .ALT file extension before using this functionality.

Named schedules are intended for broadcasts that don’t have a specific length. The Named
Schedules screen contains 20 fields for different schedules. To add a new schedule, right-click

on the field and select the desired schedule from the list.

To insert a named schedule into the Stack, click on the schedule, and click on the Insert button at
the bottom of the screen. The named schedule will be inserted just below the on-air event. Click

the Go To Main Schedule button to exit without inserting a named schedule.
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Jump + ReCue

The Jump + ReCue feature allows for resetting the next point of the current schedule. This
screen shows a list of events in the current schedule, with the next event highlighted in blue.

— The event that is currently on-air is designated with
>top<<<< in the time field. Use the Up/Down buttons to
move around in the current screen, and the PgUp/PgDn

buttons for larger moves ahead or behind in the schedule.

Click the ReCue button once the next desired event is
highlighted in blue.

Real-Time Event Table

The Real-Time Event Table is a viewer for
background events for diagnostic purposes.

Pending Events shows any current and future real-

time events, such as playing network news at the top

of an hour. In this example, the upcoming events NOW: dayl7] tme(17:00:43) LDOKING: day(7] time{17:14:56)

show a hard jump (JH), four satellite-defined liners S T s i
_ @aSOFF  GOGSOFF  GEOSOFF  GRGSOFF

(SD), a soft jump (JS), and a net record (NA). e e

e

Liner/DTMF/Macro Definitions can be viewed just

below the pending events. Click the corresponding

Netcatch Status area will show the current or most {

recently completed net catch.

button to view the current definitions for each. The
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Lift Event Prohibitions

This option requires a User Password assigned specifically for this function. Instructions for

setting passwords are in the SS32 Configuration Guide.

The Lift Event Prohibitions option allows for a 10-minute override of prohibitions, such as move,

delete, or insert, that have been set on event categories.

Record Voice Tracks

This option is for the embedded VT32 program for recording voice tracks. Instructions for

recording voice tracks are in the VT32 User Guide.

Cart Recorder

This option is for the embedded AS32 program for audio editing and recording. Instructions are
in the AS32 User Guide.

LazerBlade

LazerBlade is an embedded phone editor that can be purchased separately from the SS32.

Instructions for use are in the LazerBlade User Guide.

Redundancy

The Redundancy option is used when the SS32 system has been purchased as an SS Invincible
(hot standby). Redundancy is activated in Configuration -> Misc-1 Settings. The standby

workstation will display ‘Standby’ in the Back Timer banner.

When the Primary SS32 system is down, the Standby SS32 will be automatically activated. Use
the Hand Back button in the Redundancy option to go back to the Primary SS32 system when
ready.
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Configuration
SS32 Configuration settings are described in detail in the SS32 Configuration Guide.

This section contains the configuration for the entire SS32 system. Click on one of the fields to

open a configuration screen.

Alt vT EAS : Satellite

EvryWhr

8ys Info

Use the PgUp/PgDn buttons on the screen or the keyboard to browse through each screen.
Click the Index button at the bottom of the screen to go back to the configuration fields, and

Done to exit Configuration.

SS32 Everywhere

SS Everywhere is an option to control the main SS32 remotely and must be purchased
separately. Connection to the SS Everywhere is configured in this screen, and can also be set up

in Configuration ->SS32 Everywhere.
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Hot Button Setup

There are 30 Hot Buttons displayed at one time, and clicking the Hot+ button will bring up 30
Groups. The current Hot Button Group will be highlighted. Click on a Group to change Hot
Button screens. Adding events to Hot Buttons is explained above in the SS32 Main Screen

section.

Hot Buttons can also be defined within the Merge32 program, and the VT32 program can be
configured to use the same Hot Buttons. Instructions are included in the user guides for each

program.

05:21:27 _ Noi(B) HottE)

AIR-A

Big 80's Afternoon
What's Your Request
45

The Sign

Ace of Base Madonna: Holiday

301 DA Jingle / Mix
3:34

Bangles: Egyptian
Jingle / Mix
3:05

Drive Home Jingle
"with Jay"
:08

SheBL.':: s ':“ SHFD:. ':f So Drive Home Jingle Afternoon Traffic

"after 53" Bed #1
07 1:00

Afternoon Traffic
Bed #2

139 :

Del

CPhiew T

|

Dynamic Hot Buttons

Alternate arrangements of Hot Buttons can be set using the “Dynamic Hot Btns” setting in
Configuration -> Hot Btns. Dynamic Hot Button groups can be set to display 5x6, 2x7, or 2x6

buttons in each Group.
Click the Hot+ button, and press ALT while clicking on the Group to change the setup.

Please note that Dynamic Hot Buttons do not use the same configuration file as the regular Hot

Buttons. SS32 must be restarted, and the button functions reassigned, after selecting Dynamic.
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Insert Screen [Cart Wall]

Sort files must be created in Dispatch and the Sort files set up in SS32 Configuration ->

DataBase before the Insert screen is available.

The Insert screen displays on the right side of the screen, over the Hot Keys. The Stack will

adjust to show seven function buttons and 10 standard Sort buttons directly under it. Select the

preferred Sort for the events to be displayed, and use the Back and Next buttons to move

forward and back through the pages of events.

INSERT IN

STACK

[ ]
l
02:40:02 @
Yellow . She’s A Beauty

Coldplay B Tubes
: 11 DA 14:38:15 (301)0646 3:32 1983

Shimmer
Fuel
(2004207

Shoop
Salt-N-Pepa
(305)5285 4:00

Should | Stay Or Sho

e = = = - Clash, The
Stay The Same (301)0769 3:05 1983
Mcintyre, Joey

211 14:49:0 Show Me The Mean

Backstreet Bo!
. - (304)4333 3:51
Straight From The Heart
Adams, Bryan Siempre Coca-Cola
Agency
(COM)0017 :57

Silent Night
98 Degrees

I i
Buto IBank Hext | Listen Hours

¢ . [ — ent Night Medley
Hanson
(101)9273 413

k. y Sitver Springs
Bzt Fleetwood Mac
!! Ii!! § (305)3304 4:42 1987

KLMNOPQRSTUVWXYZ

She's So Hi
Bachman,
(304)4276 4:06 (304)4240

Collective Soul
(305)3161 4:36 1954

Short Skirt, Long Jacl
Cake
(301)4686 3:15

Show Me the Meani
Backstreet Boys
2/1( 6p) 2/09(12a)

Sign Your Name nt All These Years
D'arby, Terence Trent] Amos, Tori
(305)3147 4:06

nt Night
ive For Fighting
(305)9496 3:18 2004

s, Britney

cBride, Martina
(305)9308 2:36

Simple Kind of Life
No Doubt
(3014476 3:3 (304)d4416 3:33 =~

20
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The event labels in the Insert Screen will display differently according to the Sort that is being
used. For the Title and Music sorts, the event (cart) number, length, and year (if entered) will
display on the bottom line. When the event is selected, the bottom line will change to show the
last time the event played, and the next time it is scheduled to play.

Show Me The Meaning Show Me the Meaning

Backstreet Boys
2/ 1( 6p) 2/09{12a)

Backstreet Boys
(304H4333 J:54 77

To find a specific event, use the Banner at the bottom of the screen to narrow down the Sort.
Click on the first letter/number to refresh the Banner. The keyboard can also be used if the option

is set in Configuration -> System Settings.

The MENU sort will bring up a list of all sorts set in Dispatch, including any beyond the nine that
are displayed on the other sort buttons. Sorts that are not used often (such as Holiday Music)
can be viewed from here. The MENU button must be set up in Configuration -> Database, and

the sorts set up in Dispatch.

To insert an event into the Stack, click on the desired event, and click the blue Insert arrow that
appears in the Start area in the position where the new event is to be placed. To insert multiple
events, highlight the event, and click the green Stack button. Continue to sort and select events
to be added to the Stack. The Stack button will display S-1 and increment as more events are

selected. When finished, click the blue Insert arrow in the Start area of the Stack.

The Auto button changes Modes as it does in the main screen. Preview/Extended Preview
functionality (see above) is available using the Listen button. Select an event on the right and

click the Listen button to preview the audio from the Sort.

The Hours button will show the selected event's date and time it last aired. (This information is

also displayed in the selected event label when using

. .
the Title and Artist Sorts). H123456789TEN123456789TE
) ] 31{2;8; bbb b s b s b
In this example, the event played in the 1:00 pm D ) R
hour, but had not played for the 4 days before @ Bi/3a
February 1%. It is not scheduled to play again = SWaTEEsEmmmmmmmmmmmmmmmm
d 02/81 - 1-—————-F22
through February 3™.
B2/82  —oosooseoonoooioioiooo
02708  ——m—mmmmmmmmm e
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Index

Auto, 5, 8, 9, 21

C

Clock, 4, 5

Configuration, 1, 4,5, 6, 7, 8, 9, 10, 11, 12, 14,
17, 18, 19, 20

Countdown, 2, 3, 9, 11

D
Delete, 2, 11, 17
Device, 5

E
EOM, 8

Event, 1, 2, 3,5,6,7,8,9, 10, 11, 12, 13, 15, 16,
17,21
Event Log. See Stack

Fade, 2, 8

Hooks, 12
Hot Buttons, 7, 10, 11, 19

Insert, 7, 12, 13, 15, 17, 20, 21
Insert Screen, 12, 20, 21

L

label, 2, 3, 6, 10, 12, 21
Log, 11, 12, 13, 15

M

Manual, 1, 5, 9, 13, 17, 18, 19
Message, 6, 8

More Events. See Log

P
Preview, 10, 21

R
Re-Cue, 2

S

Stack, 1, 2, 6,7, 9, 10, 12, 13, 14, 15, 20, 21
Start, 1,2, 3,6,7,9, 13,21

T

Time. See Clock
Timer, 5, 17
title, 6, 12, 13
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DATA SERVICES MODULE : DSM32

The Data Services Module (DSM32) is a replacement for the data services portion of the Comm Module

for SS32 and Maestro systems.

There are two components to DSM32. The DSM32 Service is installed on any workstation exporting Now
Playing data to a destination such as an RDS encoder or the internet.* The DSM32 Configuration
interface is used to set up connections and Now Playing formats. You can connect to and configure any
of the DSM32 services from one instance of the DSM32 Configuration when it is opened on a workstation

that can connect to ALL workstations where a DSM32 Service is running.

*If you have multiple workstations exporting data to one workstation connected to the destination, you will
need to install multiple DSM32 Services on that workstation. Please contact customer support for

instructions in this situation.

Installation

Perform the following steps on each workstation with an individual connection to the destination (RDS

encoder, internet).

Step 1: Extract the required DSM32 files.

o

Save the DSM. zip file on the C: / drive.

o4

Right-click the DsM. zip file and select “Extract All".
Verify the files will be extracted to the “C : \DSM” folder.
d. Mark the option to show extracted files when complete. Click “Extract”.

e. Leave the folder view open for the next step.
Step 2: Install and start the DSM32 Service.

Double-click the file in C: /DSM named “install.bat”.
Wait for the prompt instruction you to press any key to install the service.

Wait for the prompt instructing you to press any key to start the service.

a o oo

This process will also create a shortcut on the Desktop for the DSM32 Configuration interface
(DSM32FIG.exe).



Step 3: Open DSM32 Configuration

Open DSM32 Configuration from the desktop shortcut or the Start menu (created in Step 2d).
Select the connection from the list presented. Click “Connect”.

c. The DSM32 Configuration “home” screen will display a banner indicating the connection status
with the DSM32 Service.

If the connection is not successful, please verify network connectivity and that the DSM32 Service is

running before contacting customer support.

Advanced Configuration: Configure Multiple DSM32 Service Addresses

The following optional steps have you enter the IP Address for each of the workstations running the
DSM32 Service into a text file. This allows you to connect to and configure any of the other DSM32

Services from one instance of the DSM32 Configuration interface. You should either:

a. Edit one text file, and then copy the file to all workstations using DSM32 so the configuration can
be opened from any of them, or
b. Select one dedicated workstation to use the DSM32 Configuration interface and just edit one text

file.

Configure multiple DSM32 Service Address(es)

a. Openthe “serviceaddr. txt” file in C: /DsM for editing.
b. Copy and paste the first line from <name> to </port> for each connection.
c. Replace the text between the tags with your system information:
a. <name></name>: Enter a unique friendly name for the workstation where the DSM32
Service is running.
b. <address></address>: Enter the IP Address for the workstation running the DSM32
Service.
C. <port></port>: Enter the Port number where the DSM32 Service will be “listening”.
The default port number is “7667”.
d. Save and close the “serviceaddr. txt” file.
e. (Optional) Copy and paste the “serviceaddr. txt” file to the C: \DsM folder on all workstations
running the DSM32 Service.
f. Close the folder view and open the DSM32 Configuration interface (Step 3, above).

If the connection is not successful, please verify network connectivity and correct IP Addresses in the

“serviceaddr.txt” file before contacting customer support.



DSM32 Home

The home screen contains buttons for DSM32 configuration, diagnostic monitoring, changing
connections, and shutting down the DSM32 Configuration Module. Closing this screen does not stop the

DSM32 Service from running.

The banner at the top of the screen displays the status to the connection selected in the previous step.

Data Services Module For $532/Maestro (DSM32)

Successful Connection To DSM32 Service

r Cunfig__ure DSM32

S53¢/Maesto

MowPlaying Pass-Thru

RDS Campaigns

Diagnostics

ROCK-FM

kMaonitor Connections

Switch Connection

Shut Down D532

Config File Path | CL'\DSM'\DS[‘-HS_ZFIG_M

The Config File Path displays the directory where the configuration file resides.

Please note that the station call letters are not displayed until the SS32/Maestro configuration is entered

and saved.

Click the $SS32/Maestro button on the main screen to begin configuration.



SS32/Maestro Configuration

The SS32/Maestro configuration determines the relationship between SS32/Maestro and DSM32. One

will be configured as the host/server, and the other will be configured as the client.

e DSM32 Acts As: In their default configuration, both SS32/Maestro are configured as the host (or
server). In this typical scenario, the DSM32 should be configured as a Client.
e Port: Enter the “in use” port number for Now Playing Data from SS32/Maestro.

o Maestro defaults to port 11108.

o The SS32 port is user configurable in the SS32’s Now Playing screen under Options ->
Configuration -> NowPlay. We suggest you change the ‘Local Address’ and ‘Destination’
socket to 11108. Once this is complete, enter 11108 into the port field.

e Connected To: Select the type of system connecting to DSM32 (SS32 or Maestro). Notice that
settings to the right will change depending on the SS32 or Maestro selection.

o 8832 Format: Select whether the RDS data export is in Format D or Format E.

o Maestro: Enables Maestro Cart Types settings (described in the next section).

e Call Letters: Enter the call letters for the station connecting to DSM32.
o DSM As Client: Enter the IP Address of SS32/Maestro in the field at the bottom of the screen.
e Special Case Cart Type: The Special Case Cart Type is used to indicate which media assets

will be treated as “Do Not Play on Internet”. In SS32, these events are tagged as “NONT”.

DSM32

Configure 5532 or Maestro Connection

DSM32 Acts As |Client -

Port 11108
Connected To  [5532 ~| |FormatD ~|
Call Letters |ROCK-FM

DSM32 As Client
IP Address of 5532/Maestro
[123.456.789.321

Special Case Cart Type
NONT

Cancel | | Save




Maestro Cart Types

Maestro users can define which cart types (as defined in Maestro Configuration) will be associated with

music events. The “Music” cart type will be selected by default.

To add a custom cart type, enter the name in the field below the list and click “Add”. To delete a cart

type, highlight it in the list (by clicking once) and click the “Delete” button.

The Special Case Cart Type is used to indicate which Maestro Cart Type will be treated as “Do Not Play

on Internet”. Maestro users will enter the Cart Type name in this field.

D5M32

Configure 5532 or Maestro Connection
Maestro Cart Types

Check to Indicate MUSIC
¥ Music

Commercials
¥| Holiday

DSM32 Acts As |Client -
Port 11108
Connected To Maestro - —

Call Letters |RC'CK'FhIIII

DSM32 As Client
IP Address of S532/Maestro
[123.456.789.321 | Add

Special Case Cart Type

|C|:|mmen::iﬁ|s

Cancel | ! Save |

Click “Save” to return to the main screen. Click the Now Playing Pass-Thru button on the main screen

to continue.



Now Playing Pass-Thru

The Now Playing Pass-Thru configuration allows duplicate Now Playing data to be made available in a

variety of formats to multiple sources (i.e. streaming computers or other web-based services).
Double-click the <create new> line in the Connections screen.

o Name/Description: Enter a unique name for the connection.

e |f DSM32 is to act as a server to the destination workstation, select “Listen” as the Style type,
enter 0.0.0.0 as the IP Address, and enter the desired Port number to listen on. DSM32 will
allow the destination workstation to retrieve the Now Playing data at the local IP of the DSM32
workstation.

e |f DSM32 is to act as a client to the destination workstation, select “Send” as the Style type and
enter the IP Address and Port number of the destination workstation. DSM32 will push the Now
Playing data information to this address.

e Protocol: Enter the desired protocol to use. If file’ mode is selected, enter the entire path plus
the file name into the field above.

e Format: Select the desired pass-through format from the drop down list. (See examples of the
various export formats). When you select “User-Defined”, an “Edit” button appears. Click this
button to open the User-Defined Template screen (example on next page).

e Options: Select from the list of predefined modifiers for the Format selection above.

DSM32
Edit Connection [ID=1]
Name/Description |AFA Listening Connection

IP Address 0.0.0.0

Port ’W

Protocol TCP hd

Format D &

Style m DS5M32 act as Server
Options

[ Formats E+XML: Append Carriage-Return (CR) Char
[ Formats A+E+XML: Append Line Feed (LF) Char

[ Formats C+D+XML: Send Only First (Flaying) Line

[+ Format D: Don't Send Ending Countdown

[ Formats A+E+XML: Send Music ("SONG") Events Only

[ Formats A+C+D+E: Trim Output (Remove Trailing Spaces)

[ Formats A+C+D+E: Prepend This Text: |NUVﬁ|UE

[ Formats A+C+D+E: Append This Text |NDV&|UE

Cancel| |




User-Defined Template

Enter your user-defined template for the Now Playing export format using the Variables and Options
defined on the screen. You can modify an existing format (A, C, D, and E) by clicking the button in the

“Pre-Built Formats” section and modifying the variables in the template field (top of screen).

Click “Done” to save the user-defined template and return to the Connections screen.

DSM32

User-Defined Template:

|@T @AGL
Yarniables Options Pre-Built Formats
@4 = Arist o ]
— lli FT - Fix Titla Width 7oA A,
v A - Fix Ardist YWicdth 28 4| C
{&E = Etc/Trivia J—|
@L = Length [ FE - Fix Etc/Trivia Width LR N D
@ = Type (song/spat) [ TR-Trim Title, Artist and Etc Fields E

@@ = Literal '@ [ S0-Send'Sang' Events Only
(@G = Cateqory [ SF-Send'Spot' Events Only
@C = Cart [ MP-Don'tPad Category

@l = Intro r

@D = Ending (C.F.etc)
(&@F = Flaying (F) (or C)
(&5 = Countdown

{gr = CR character
{gn = LF character

- 5 4] ]

Click “Save” to return to the main screen. Click the RDS Campaigns button on the main screen.



RDS Campaigns

The Campaign configuration screen allows you to define your RDS encoder output settings, as well as set

specific rules for exported text. For example, you could set a campaign to display the station slogan or

advertiser sponsored text during commercials, or display upcoming concert information for a specific artist

when their latest song airs.

To set up your RDS Encoder settings:

Type: Select your encoder type from the drop-down menu. If your encoder type is not listed,

select “User Defined”.
IP Address and Port: Enter the destination IP address and Port Number for the RDS encoder.

Protocol: Select the desired protocol to use from the drop-down list. Consult your RDS encoder

manual for more information about which Protocol to use.

o

Selections for TCP (Transmission Control Protocol) and UDP (Universal Datagram
Protocol) will send ASCII formatting. Note that Inovonics® units are limited to TCP output
only.

The UECP (Universal Encoder Communication Protocol) selection will send modified
Audemat® UECP encoding over UDP that should be backward compatible with all
Aztec® and Burk® devices.

UECP2 will send standard UECP encoding over UDP to these devices. Firmware 3780
or higher is required to use UECP2.

PS: The PS setting defaults to Static mode. Use the drop-down menu to access the advanced

option that allows you to send Dynamic PS instead of Static.

o

The default Static mode indicates text events will be sent to the RDS encoder in 8-
character (PS=segments) in Block mode. This is the traditional behavior of the original
Comm Module.

Dynamic PS instead of static (prefixed as DPS= or PS_SCROLL=) to the RDS encoder.
When this setting is selected, the RDS encoder itself takes care of parsing the output text
internally and additional parameters must be configured on the encoder. Please
reference the RDS encoder manual for individual unit configuration settings. [Aztec/Burk

units require Firmware Version 3780.x or greater from www.audemat-aztec.com to

enable this functionality].

Note that the Dynamic PS output is limited to 64 characters as a time. Campaigns over this character

limit will be truncated.

Default PS Msg: Enter a default PS message (up to 8 characters).

Refresh Rate: Confirm your default refresh rate in seconds from the drop down menu.


http://www.audemat-aztec.com/

e Radio Text (64): Mark the option for Radio Text (64) to send the identical campaigns as
radiotext (i.e. TEXT= or RT=) to your RDS encoder.

o The option for Radio Text (64) will send the identical campaigns as radiotext (i.e. TEXT=

or RT=) to your RDS encoder. Radiotext carries the same 64-character limit as Dynamic

PS and campaigns over this character limit will be truncated. It may be sent concurrently

with either Static OR Dynamic PS. Radiotext may require additional configuration on the

RDS encoder Please reference the RDS encoder manual for individual unit configuration

settings. [Aztec/Burk units require Firmware Version 3780.x or greater from

www.audemat-aztec.com to enable this functionality].

e Radio Freq: Enter the radio frequency of the station being configured.
e Slogan: Enter the station slogan. The field next to the slogan displays the total time it will take to

run the slogan depending on the Refresh Rate previously selected.

Options

Ignore ‘NONT’ Type: Selecting this option will prevent NONT (Do Not Play on Internet) events from
being output over the RDS.

Publish Spot Titles: Selection this option will allow spot titles to be output from the RDS encoder.

DSM32

Configure Campaigns
RDS Encoder

Type [AztecFMB80  ~| IP Address |123.456.789.322 Port [5007
Protocol (UDP  v| PS |Static | Default PS Msg |Rock 104

Refresh Rate (secs) |1.8  ~ [~ RadioText (64) Radio Freq |104.1

Slogan [104.1 FM Your Home For Rock Slogan 7.2 secs

Options = =
[ Ignore 'NONT"' Type v Publish Spot Titles

Campaigns (Highlight Then Use Button [DoubleClick = Edit] )

Default Campaians

< A\ > .
creale new Edit

Delete
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Set up the Default Campaign

Double-click the “Default Campaigns” line in the Campaigns screen.

Replace the “NoValue” text with your custom text fields along with Title and Artist wildcards (in the drop-
down menus). This information will be sent (from top to bottom) to the RDS encoder while defined music
cuts are playing.

Leaving the ‘NoValue’ text in a field will omit that field from being sent to the RDS encoder.

DSM32
Edit Default Campaigns
Music Campaign
Text Part #1 |N|:|w Playing

Title or Artis|Title -

Text Part #2 |by

Title or Artis|Artist ~

Text Part #3 ||:|n Rock 104

Spot Campaign
Text Part #1 Tell

Spot Name Appears Here

Text Part #2 |R|:||::k 104 sent you. ..

MNote: Use Special Text "Novalue" to skip over any field. Cancel

Enter your Default Campaign settings and click “Save” to return to the Campaign configuration.



Set up Custom Campaigns

Double-click the <create new> line in the Campaigns screen.

Enter a unique Name for the campaign. The Enable drop-down list allows you to disable and re-enable a
campaign while retaining the previously entered values. A ‘Disabled’ campaign will not be triggered, and

is grayed out under the campaign menu.

Next, select a Campaign Trigger Type from the drop-down list. Note that additional fields may appear

depending on the type of campaign selected.
Campaign Trigger Types:

e Ad Matching: will be triggered when the ‘Title’ field of a spot matches the include list.
e Artist Matching: will be triggered when the ‘Artist’ field of a song matches the include list.
e Open Inventory: will be triggered when no other criteria is met.

o Title Matching: will be triggered when the ‘Title’ field of a song matches the include list.

If you have selected a type that requires text to trigger the campaign, enter the “include” value in the field
under the “Matching These Advertisers” list. Click “Add” to add the values to this list.

Use the “Find” button to search for an existing advertiser. You may also select a value from the historical
RDS data using the “Find” button. Select a value from the Find menu and click 'Add' to append the value
to the list.

Cheddar is better at Pete's House of Cheese!
Edit Campaign [ID=1]
Name |Pete's House of Cheese Enabled ﬂ

Type Ad Matching ~ | Matching These Advertisers
Priority  [Medium + | |Pete’s

Start Date | 4/20/2009 ¥ Delete

Play Thru 541872009 v

Minimum Minutes Find
Between Plays 15 b 1

Repeat Rate ]Cuntinuuus ﬂ | Add

Campaign Text (wlidcards: _StationName_ _Frequency_ _Slogan_)
|Cheddar is better at Pete's House of Cheese!

Day/Hour Restrictions  (Black =Blocke

Mon M 1123456 78 SelectAl
Mitlzialadolefz 8l Claar Al

Wed M1 2 3 456 7 & el

Thu |1 2 5314 5 6 7 &

Fri #1 2 34 5 6 7 8

Ssat M 1.2 3456 783101 QI

Sun M1 23456 78 91011

LastUsed: | Noalue Use After: MNovalue 126 secs




Priority can be adjusted to one of five values: Lowest, Low, Medium, High, and Highest to assist with

conflict resolution. The default priority is Medium.

The Start Date and Play Thru dates define the first day a campaign will run and the last date a campaign

will run through.

The Minimum Minutes Between Plays selection will set the minimum period of time that must elapse
before the campaign screen is open to play again. A value of ‘None’ will cycle the campaign indefinitely

until the next element in started.

The Repeat Rate selection allows fine-tuning a campaign as it will determine the frequency of a

campaign within the campaign screen.

The text entered in the Campaign Text field will be displayed when the campaign is triggered. Type your
own text in the field, or enter one or all of the “wildcards” displayed under the text field. You must enter

these exactly like the examples:

e StationName will be taken from the “Station Name” field in the SS32/Maestro configuration
screen.
e  Frequency_ Will be taken from the “Radio Freq” field in the Configure Campaign main screen.

e Slogan_ will be taken from the “Slogan” field in the Configure Campaign main screen.

The Day/Hour Restrictions area allows you to define the hours and days of the week that a campaign
can be triggered. All days and hours are enabled (in green) by default. Restricted hours and days are

denoted in black. Simply click on the hour in the grid to change the restrictions.

The Last Used field displays the last date and time the campaign was triggered. The Use After field will
display the next available run time for the campaign. The Publish In field serves as a counter for the

repeat rate.



Diagnostics

The diagnostic screen provides a quick way to monitor the incoming data to the DSM32 service from your
SS32/Maestro system. Click the Monitor Connections button on the main screen to open the

Diagnostics screen.

The Monitor Now Playing screen displays the text being generated from SS32/Maestro to DSM32 when

the monitor box is checked. Switch the view by clicking the box to display Encoder Replies.
The Connection Activity displays the Foreign Address connection for diagnostic purposes.

Use the “Clear” button next to each of these screens to clear the screen and monitor new information

coming in.

The Logging Option selections will record the selected data (configuration editing, socket activity, or

campaign logic) in a DSM32Log. txt file in the DSM32 directory.

The Send Format-D and Sent XML buttons send a test output in the selected format to all sockets.

DSM32 Diagnostics
Monitor: [+ MNow Playing from 5532/Maestro [~ Encoder Replies Clear
L 0B00SPOTOZLIner 2 ROTATOR FPO0COD:04LA 0001 SPOTOZLiner 1 LEGAL -
L1 0600SPOTO Liner 2 ROTATOR PO0COD:04LA 0001 SPOTOLiner 1 LEGAL
L1 0600SPOTOOLINEY 2 ROTATOR FO0CO0:04LA 0001 SPOTA0LIner 1 LEGAL
LHa001SFOT Linerd LEGAL POOFO0:04L1 0B0OSFOT Liner 3 ROTATOR
L0001 SFOTOALIner 1 LEGAL POOFO0:04L1 06A0SPOTO3LIner 3 ROTATOR
L0001 SFOTOZLiner 1 LEGAL POOFO0:04L1 06A0SPOTOZLINEr 3 ROTATOR
L0001 SFOTO Liner 1 LEGAL POOFO0:04L1 06A0SFOTO Liner 3 ROTATOR
) [’
Connection Activity Clear
Connection Closed 172.29.106.95 Port=5005 Sample to All Connects
Connection Completed 172.29.106.95 Port=5005 Send Format-D
Connection Closed 172.29.106.95 Port=5005 Sand KL
Connection Completed 172.29.106.95 Port=5005
Connection Closed 172.29.106.95 Port=5005 Logging Optians
v Log Edit Activity
[ Log Socket Activity
[+ Log Campaign Logic




Now Playing Examples

Formats D and E are the only two formats SS32 can export to DSM32. DSM32 can export in formats A,
C, D, E, XML, and User-Defined.

Now Playing data exported from a pass-through when connected to a Maestro system will only export the

current on-air event.

Format A

TEXT= <<title [37 bytes]>> <<two spaces>> <<artist [25 bytes] >> CR for a total length of 70 bytes. Title

and artist fields are truncated as needed to fit in the respective locations.

Text=0Once Bitten, Twice Shy Great White

Format C

CAT(3)/CART(4)/TYPE(4)/TITLE(28)/ARTIST(28)/STATUS(1)/LENGTH(5)/CR/LF

1109054SONGOnce Bitten, Twice Shy Great White
P04:59

1031058NONTHello It's Me Rundgren, Todd
C03:38

SWPO200SPOTPETERS .
C00:02

1052205SONGI Want You To Want Me Cheap Trick
C02:56

4010127SONGA Hard Day's Night Beatles, The
C02:24

4010181SONGRunaway Shannon, Del
Cc02:13

4032338SONGSouthern Man Young, Neil
C05:20

SWP0201SPOTMILKBONE _—
C00:04



Format D

CAT(3)/CART(4)/TYPE(4)/WARN(2)/TITLE(28)/ARTIST(28)/STATUS(1)/INTRO(2)/END(1)/LENGTH(5)/C
RILF

1109054SONG Once Bitten, Twice Shy Great White
P21F04:59

1031058NONT Hello It's Me Rundgren, Todd
Cl12F03:38

SWP0200SPOT PETERS _—
COO0F00:02

1052205SONG I Want You To Want Me Cheap Trick
Cl0F02:56

4010127SONG A Hard Day's Night Beatles, The
CO02F02:24

4010181SONG Runaway Shannon, Del
CO06F02:13

4032338SONG Southern Man Young, Neil
Cl3F05:20

SWP0201SPOT MILKBONE _
CO0F00:04

Format E

CAT(3)/CART(4)/TYPE(4)/TITLE(43)/ARTIST(34)/TRIVIA(34)/INTRO(2)/END(1)/LENGTH(5)/NULLBYTE(
1)

1109054SONGOnce Bitten, Twice Shy Great White

..Twice Shy 21F04:59



XML

This is an example of the XML export format saved in a text file.

Note that XML exported from the pass-through when connected to a Maestro system will only export the

current on-air event.

<NowPlaying=<Call=GGLA-FM=</Call><Events=<5532Event pos="0"
valid="true"><Catld>110</Catld><Cutld>9054</Cutld><Type>S0ONG
</Type=<5econdsRemaining= </SecondsRemaining=<Title><I[CDATA
[Once Bitten, Twice Shy [z </Title=<Artist=<I[CDATA[Great White
[|=</Artist=<Intro=21</Intro><Len>04:59</Len><Raw=<I[CDATA
[110905450NG Once Bitten, Twice Shy Great White
P21F04:59]]></Raw=>=</5532Event><5532Event pos="1" valid="true">
<Catld=103</Catld=<Cutld=1058</Cutld><Type=NONT</Type=
<SecondsRemaining> </SecondsRemaining=<Title><I[CDATA[Hello

It's Me 1= </Title><Artist><I[CDATA[Rundgren, Todd 1=
</Artist=<Intro=12</Intro><Len>03:38</Len><Raw=><I[CDATA
[1031058NONTHello It's Me Rundgren, Todd

C12F03:38]]></Raw></5532Event><5532Event pos="2" valid="true">
<Catld>SWP</Catld><Cutld>0200</Cutld><Type>SPOT</Type>
<SecondsRemaining= </SecondsRemaining=<Title=<I[CDATA

[PETERS []=</Mitle><Artist><I[ CDATA[-—
[1=</Artist=<Intro=00</Intro=<Len=00:02</Len=<Raw=<I[CDATA
[SWP0200SPOT PETERS — CO0F00:02])=

2 IDoaws< I CYIFuonts < QCYIMFuontnine =" hid—"tria"s <M atld=1N&
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